Des Exercices Sur alGorithme

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Des Exercices Sur alGorithme

Message par lotfreestylekeni le Mer Jan 05, 2011 9:57 pm

si vous avez des exercices d'algo en peu travailler ensemble



lotfreestylekeni
 
 

Nombre de messages : 2
Date d'inscription : 05/01/2011
Masculin

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Des Exercices Sur alGorithme

Message par hamza338 le Dim Jan 09, 2011 10:48 pm

salut l'ami,

peut tu m'aider a trouve une solution por se algo:
Etablir un algorithme qui demande de saisir 3 entier A,B,C, et puis determine les racines de l'equation ax carre +bx-c=0.

merci.



hamza338
 
 

Nombre de messages : 15
Date d'inscription : 20/11/2010
Masculin

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Des Exercices Sur alGorithme

Message par abdellah2 le Ven Jan 14, 2011 10:42 pm

peut tu m'aider a trouve les solutions de 2 exercices slvp
Exercice 1 - Nombres parfaits
Un nombre parfait est un nombre egal a la somme de ses diviseurs stricts. Par exemple, 6 a pour diviseurs
stricts 1, 2 et 3, comme 1 + 2 + 3 = 6, alors 6 est parfait.
1. Est-ce que 18 est parfait ?
2. Est-ce que 28 est parfait ?
3. Que dire d'un nombre ami avec lui-m^eme ?
4. Ecrire la fonction int estParfait(int n), elle doit retourner 1 si n est un nombre parfait, 0 sinon.
Exercice 2 - Nombres de Kaprekar
Un nombre n est un nombre de Kaprekar en base 10, si la representation decimale de n2 peut ^etre separee
en une partie gauche u et une partie droite v tel que u + v = n. 452 = 2025, comme 20 + 25 = 45, 45 est
aussi un nombre de Kaprekar. 48792 = 23804641, comme 238 + 04641 = 4879 (le 0 de 046641 est inutile,
je l'ai juste place pour eviter toute confusion), alors 4879 est encore un nombre de Kaprekar.
1. Est-ce que 9 est un nombre de Kaprekar ?
2. Ecrire la fonction int sommeParties(int n, int p) qui decoupe n est deux nombres dont le
deuxieme comporte p chi res, et aui retourne leur somme. Par exemple,
sommeParties(12540; 2) = 125 + 40 = 165
3. Ecrire la fonction int estKaprekar(int n)[b]
lol!



abdellah2
 
 

Nombre de messages : 1
Date d'inscription : 30/12/2010
Masculin

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Des Exercices Sur alGorithme

Message par mahdi spox le Dim Fév 20, 2011 1:54 pm

ex 1
4-- int estparfait(int n)
{ int i,c,somme
ecrire" donner votre valeur"
lire n
somme=0
c=0
pour i=1 a n-1
si(n%i=0)
somme=somme+i
finsi
si(somme=n)
c=1
finsi
finpoure
return c; }



mahdi spox
 
 

Nombre de messages : 7
Date d'inscription : 03/09/2010
Masculin

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: Des Exercices Sur alGorithme

Message par Mr.Hicham le Lun Fév 21, 2011 11:17 pm

@hamza338 a écrit:salut l'ami,

peut tu m'aider a trouve une solution por se algo:
Etablir un algorithme qui demande de saisir 3 entier A,B,C, et puis determine les racines de l'equation ax carre +bx-c=0.

merci.

Code:

variable :
a,b,c : entier
x,x1,x2 : réel
delta : entier

Afficher("Saisir a,b et c :")
lire(a,b,c)

si (a=0 et b<>0 et c<>0) alors
x = -c/b
afficher(" x = " , x)
sinon si (a=0 et b=0 et c=0) alors
afficher(" Solution R ")
sinon si (a=0 et b=0 et c<>0) alors
afficher(" Impossible ")
sinon si (a<>0) alors
delta <--- b*b-4*c*a
x1 <--- -b+racine(delta)/2*a
x1 <--- -b-racine(delta)/2*a
si (delta > 0) alors
afficher(" x1 = ", x1 ,"et x2 = ", x2)
sinon si (delta < 0) alors
afficher(" pas de solution dans R ")
sinon
x <--- -b/2*a
afficher(" x = ", x)
fin si
fin si



Mr.Hicham
 
 

Nombre de messages : 464
Date d'inscription : 25/05/2010
Masculin

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum